There are a couple of reasons why you might running through some issues:

1-Your host is just taking some time to update your new CNAME.
2-CNAME is not pointing
to custom.clustdoc.com
3-The password entered in Clust is not the right one
4-You haven't yet clicked on the 'Confirm' button in the confirmation email sent from Clust after you've entered your SMTP settings
5-SMTP username and SMTP sender email are different in Clust (see below)
6- You do not have yet a Gold account
7- Your confirmation was sent to your spam folder
8- Your confirmation email was sent to your Clust user email inbox (and you've checked your email sender's)

If your CNAME looks right, and you have waited for a couple of hours for it to update, contact your registrar to ask why the CNAME is not propagated yet if it has been set up correctly.

  • How to troubleshoot SMTP?

Here are some tips to troubleshoot most frequent issues with SMTP and email deliverability. Remember that using a professional SMTP service can help you solve most issues.

  • Check again your username and password.
  • SMTP normally uses port 25, but it may happen to be blocked by your ISP: try switch to port 587 (or port 465 if you’re connecting via SSL).
  • The SMTP settings are mistaken. Maybe you configured your mail client with a wrong outgoing server name.
  • Firewall or antivirus issues. Make sure that you have an exception rule for your SMTP service in your firewall, proxy service or antivirus settings.

If you keep running into issues, it’s likely that you have a general issue with your Internet Service Provider (which you should contact immediately).

We made up a list the most common email providers, in order to help you setup your SMTP configuration more easily. 

Did this answer your question?